High response time of search queries
Resolved
Jan 27 at 09:00am HST
We identified the root cause of the high response times and resolved the issue. An API account sent an overwhelming number of search requests in a short period, effectively DDoS-ing our Elasticsearch cluster. To address this, we implemented aggressive rate limits for this specific account. The Elasticsearch cluster has since recovered, and everything is back to normal.
Affected services
listennotes.com
Podcast API Production
ListenNotes.com Response Time
Listen Notes Podcast API Response Time
Created
Jan 27 at 08:23am HST
We are experiencing high response times for search queries, which has impacted the Podcast API and ListenNotes.com.
Affected services
listennotes.com
Podcast API Production
ListenNotes.com Response Time
Listen Notes Podcast API Response Time